Datto Networking - Secure Edge Data Usage Reporting Issue

Incident Report for Kaseya Inc

Resolved

The issue preventing Secure Edge administrators from viewing recent usage information within Datto Network Manager has been resolved.

Queued data has finished processing, and usage metrics are now available as expected. We appreciate your patience while we worked through this issue.

Subscribe to the Kaseya Status Page for up to date information at https://status.kaseya.com/
Posted Sep 02, 2026 - 19:17 EDT

Identified

We're aware of an issue preventing Secure Edge administrators from viewing recent usage information within Datto Network Manager. We've identified the root cause of the issue. Queued data has resumed processing and we're expecting metrics to become available again within a few hours. We will update this post as we continue to monitor and work through the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 02, 2026 - 17:11 EDT
This incident affected: Datto Networking (Secure Edge).