Datto SaaS Protection - Backup performance degradation for SharePoint services on pod 'des1-saas-p0'

Incident Report for Kaseya Inc

Monitoring

Configuration changes have been implemented to address the issue and SharePoint backups are stable.

The Kaseya R&D team is monitoring.
Posted Jul 16, 2025 - 08:43 EDT

Identified

The Kaseya R&D team has identified the issue and are actively working to resolve it.
Posted Jul 14, 2025 - 12:59 EDT

Investigating

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'des1-saas-p0' may experience degraded SharePoint backup performance.


The Kaseya R&D Team is currently investigating this issue.


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 14, 2025 - 09:29 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).