RocketCyber- 504 errors experienced on US Portal

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 12:07 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 11:06 EDT

Investigating

We are currently investigating reports of 504 errors being experienced when navigating the US RocketCyber portal. Our engineering teams are working to understand the root cause and provide a solutions. We will provide another updates as soon as we have more information.
Posted Jul 14, 2025 - 10:57 EDT
This incident affected: RocketCyber (EU).