Datto Endpoint Backup for PC - Germany - Degraded Service Performance Affecting Select Infrastructure Nodes

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 14:18 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2026 - 11:58 EDT

Investigating

We are aware of a problem where Datto Endpoint Backup for PC users in the Germany region, paired to 'des1-dtc-server-30', 'des1-dtc-server-32' and 'des1-dtc-server-33' will experience degraded offsite performance, which may affect backup and recovery operations.

The Kaseya Engineering Team is currently investigating the issue and working towards a resolution.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 26, 2026 - 10:40 EDT
This incident affected: Datto / Unitrends Endpoint Backup for PCs (Backup, Recovery).