Datto Endpoint Backup v2 - Temporary Issue Affecting New Backups and Restores

Incident Report for Kaseya Inc

Resolved

The issue preventing new backups, restores, and pairings has been resolved, and services are fully operational. Existing backups and services were not impacted. We appreciate your patience while we worked to resolve this.
Posted Jul 08, 2025 - 23:09 EDT

Investigating

We’re currently experiencing an issue preventing new backups, restores, and pairings. Existing backups and services are not impacted. Our team is investigating, and we’ll provide updates as we have them.

Subscribe to receive up-to-date notifications on future maintenance periods by visiting https://status.kaseya.com/
Posted Jul 08, 2025 - 21:10 EDT
This incident affected: Endpoint Backup V2 (Backup, Agent Registration, Restore).