Datto SaaS Protection - Backup performance degradation on pod 'use1-saas-p2'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 08:23 EDT

Monitoring

Changes have been implemented to address the issue and the R&D team is actively monitoring the results.
Posted Sep 15, 2025 - 11:21 EDT

Identified

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'use1-saas-p2' may experience degraded backup performance for some services.


The Kaseya R&D Team has identified the issue and are actively working to resolve it.


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 15, 2025 - 08:26 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).