Datto BCDR - Devices running the latest build may generate incorrect S.M.A.R.T. hard drive alerts, even when the drives are functioning properly.

Incident Report for Kaseya Inc

Postmortem

Starting on April 10 at 7:10PM UTC, a subset of 5% of the BCDR On Prem Device Partner fleet experienced a service interruption which caused them to receive false positive hard drive failure alerts if their devices contained certain models of Western Digital HDDs. 

The root cause for this service interruption was deploying updates to drive health reporting of SMART data from disk drives in partner devices.  This data is used to measure when a partner alert to replace a failing drive should be sent.

Efforts to improve overall drive health reporting and make it clear and useful to our partners remain ongoing.  

Our Engineering team deployed a fix to correct the problem on April 16 at 7:00 PM UTC. 

To prevent this issue from occurring in the future, we have added exceptions to upload raw values for all SMART statistics that drive portal hard drive alerting.

Posted Apr 25, 2025 - 09:31 EDT

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 09:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2025 - 16:20 EDT

Identified

We are aware of a problem where BCDR devices running the latest device OS (IBU version) are generating inaccurate alerts for 'Calibration_Retry_Count / Spin_Retry_Count' smartctl attributes even when the drives are functioning properly.



The Kaseya R&D Team has identified the issue and is working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Apr 15, 2025 - 14:22 EDT
This incident affected: Datto BCDR Devices (Device Hardware).