Datto SaaS Protection - Backup performance degradation for Exchange services on pod 'use1-saas-p7'

Incident Report for Kaseya Inc

Update

Backup success rate metrics for Exchange services on pod 'use1-saas-p7' have returned to normal levels and remain stable.

Our R&D team is continuing to monitor for any other issues.
Posted Aug 31, 2026 - 09:27 EDT

Update

Backup success rates for Exchange services on pod 'use1-saas-p7' continue to improve following the changes that have been implemented. Our R&D team continues to closely monitor system performance and backup outcomes to ensure the positive trend is maintained.
Posted Aug 28, 2026 - 16:30 EDT

Monitoring

Backup success rates for Exchange services on pod 'use1-saas-p7' continue to improve. Additional changes have been applied to further address the Exchange backup performance issue and our R&D team is closely monitoring the results.
Posted Aug 28, 2026 - 13:18 EDT

Update

Our R&D team has deployed additional changes to further address the issue and Exchange backup performance on pod 'use1-saas-p7' is improving.
Posted Aug 28, 2026 - 09:49 EDT

Identified

Our R&D team has identified an issue causing the degraded backup performance for Exchange services on pod 'use1-saas-p7'. Configuration changes have been implemented to help mitigate the issue and additional changes are being prepared for deployment to further address Exchange backup performance.
Posted Aug 28, 2026 - 08:40 EDT

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 13:38 EDT

Investigating

We are aware of a problem where some customers hosted on pod 'use1-saas-p7' are currently experiencing degraded backup performance for Exchange services.

The Kaseya Engineering Team is actively investigating.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 27, 2026 - 10:52 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).