Datto SaaS Protection - Service disruption affecting customers hosted on pod 'gbe2-saas-p0'

Incident Report for Kaseya Inc

Resolved

Backups continue to process and all customer accounts hosted on pod 'gbe2-saas-p0' are accessible and functioning normally.

This incident is resolved.
Posted Jul 29, 2026 - 16:15 EDT

Monitoring

Our R&D team has implemented additional changes to address the intermittent account access issues that were still affecting some customers hosted on pod 'gbe2-saas-p0' and backups for all services are continuing to process.

We will be monitoring the pod closely for any other issues.
Posted Jul 29, 2026 - 13:12 EDT

Update

Our R&D team is continuing to address the account access issues still affecting some SaaS Protection customers hosted on pod 'gbe2-saas-p0' as well as monitoring backup performance.
Posted Jul 29, 2026 - 12:38 EDT

Update

Our R&D team has confirmed that backups are currently processing on pod 'gbe2-saas-p0' however they are continuing to address an issue affecting customer account access.
Posted Jul 29, 2026 - 11:02 EDT

Update

Our R&D team is continuing to address the issue and fully restore SaaS Protection services on pod 'gbe2-saas-p0'.
Posted Jul 29, 2026 - 09:45 EDT

Update

Our R&D team has applied a fix to address the issue and they are currently verifying restoration of all services on pod 'gbe2-saas-p0'.
Posted Jul 29, 2026 - 08:23 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 29, 2026 - 06:56 EDT

Identified

We are aware of an issue where Datto SaaS Protection customers hosted on pod 'gbe2-saas-p0' are experiencing a disruption to all SaaS Protection services.

The Kaseya Engineering Team has identified the issue and is actively working to restore service as quickly as possible.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 29, 2026 - 06:55 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Seat Management, SaaS Protection Restores/Exports).