Datto SaaS Protection - Node 'caw1-bfyii-311' - Maintenance Notice

Incident Report for Kaseya Inc

Monitoring

Maintenance has completed and all services on node 'caw1-bfyii-311' are online and functioning normally.

Our R&D team is monitoring.
Posted Oct 31, 2025 - 15:07 EDT

Identified

We are currently performing maintenance on Datto SaaS Protection node ‘caw1-bfyii-311' requiring the node to be taken offline temporarily. The maintenance is estimated to take 3-4 days to complete.

During this downtime, customers hosted on node ‘caw1-bfyii-311' will experience impact to systems and related services to Datto SaaS Protection including:

Account access
Backups
Restores/Exports
Seat Management

Subscribe to receive up-to-date notifications on future maintenance periods by visiting https://status.kaseya.com/
Posted Oct 28, 2025 - 16:42 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Seat Management).