Following additional changes deployed by our R&D team, we are seeing continued improvement in Exchange backup success rates for customers hosted on pod 'aue1-saas-p0'.
Our team is closely monitoring the environment as backup processing and success rates continue to recover.
Posted Sep 04, 2026 - 12:47 EDT
Update
Following the recent changes deployed by our R&D team, we are seeing improvements in Exchange backup success rates for customers hosted on pod 'aue1-saas-p0'. Our team remains actively engaged and continues to work on further improvements while closely monitoring the environment.
Posted Sep 03, 2026 - 15:31 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 09:40 EDT
Identified
Our R&D team has identified the issue and have started deploying changes to mitigate the Exchange backup performance issues for customers hosted on pod 'aue1-saas-p0'
Posted Sep 02, 2026 - 16:56 EDT
Investigating
We are aware of a problem where some customers hosted on pod 'aue1-saas-p0' are currently experiencing degraded backup performance for Exchange services.
The Kaseya Engineering Team is actively investigating.