ConnectBooster - Live - Paya ACH Processing Outage
Incident Report for Kaseya Inc
Resolved
The Processing Partner, Paya has reported that this situation is now resolved.

If you have any questions on current ACH Transactions that were ran through ConnectBooster, please reach out to our payments team at payments@connectbooster.com for assistance with validation. Alternatively, you can confirm their status within the BNG Gateway.

We appreciate your patience as this situation was addressed.

Thank you,
Posted Dec 09, 2024 - 09:27 EST
Identified
The Kaseya team has been made aware that for individuals using Paya for their ACH processing, an outage has been reported and been advised to delay ACH Processing until this has been resolved.

If you have transaction that you would like to verify, please submit a ticket with our payments support team for the fastest response at payments@connectbooster.com as we are experiencing a high volume of calls.

We will continue to provide more information as it can be made available.

Thank you,
Posted Dec 06, 2024 - 17:10 EST
This incident affected: Connectbooster (Portal, Payments, Point of Sale, Secure Payments).