Datto SaaS Protection - 500 Error When Accessing SaaS Protection Status Page in Datto Partner Portal

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 16:01 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2026 - 14:56 EDT

Identified

The system is recovering after the R&D team took steps to resolve the issue.

Some customer may still experience issues accessing the SaaS Protection Status Page while the system is recovering.
Posted Sep 21, 2026 - 05:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2026 - 04:55 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 21, 2026 - 04:47 EDT

Investigating

We are aware of a problem where Datto SaaS Protection Partners were receiving a 500 error when attempting to access the SaaS Protection Status Page within the Datto Partner Portal.

The Kaseya Engineering Team has been involved and they are investigating the issue.
Posted Sep 21, 2026 - 01:40 EDT
This incident affected: Datto Partner Portal (Status Components).