Datto BCDR - Server5465 - Offsite Sync and Offsite Restore Functionality Impacted

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 08:52 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2026 - 11:42 EDT

Investigating

We are aware of a problem where Datto BCDR users associated with Server5465 may experience disruptions affecting offsite synchronization and offsite restore operations.

The Kaseya R&D Team is currently investigating the issue and working towards a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 20, 2026 - 09:33 EDT
This incident affected: Datto BCDR Devices (Off-Site Synchronization, Recovery, Disaster Recovery Team, Off-Site Recovery).