Datto SaaS Protection - Backup performance degradation on pods 'use1-saas-p7' and 'use1-saas-p8'

Incident Report for Kaseya Inc

Update

Backups are processing normally again on pod 'use1-saas-p7' and backup success rate metrics are improving.

The R&D team has identified another issue still affecting backups on pod 'use1-saas-p8' and they are actively working to resolve it.
Posted Mar 20, 2026 - 10:16 EDT

Identified

The R&D team identified the root cause of the problem and they are working on resolving the issue.
Posted Mar 20, 2026 - 08:05 EDT

Investigating

We are currently investigating an issue affecting some customers hosted on pods 'use1-saas-p7' and 'use1-saas-p8', where performance degradation has been observed affecting all backups.

The Kaseya R&D team has identified the root cause and is actively working on a resolution. Further updates will be provided as progress is made.
Posted Mar 20, 2026 - 07:39 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).