Endpoint Backup v2 - Agent Deployment Errors in the UK Region

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 10:40 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2026 - 10:25 EST

Investigating

We are aware of a problem where new Endpoint Backup v2 deployments in the UK region will fail to process.

The Kaseya R&D Team has identified the issue and is working towards a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jan 09, 2026 - 15:56 EST
This incident affected: Endpoint Backup V2 (Agent Registration).