Kaseya Quote Manager - Intermittent 504 Error

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 10:11 EDT

Monitoring

Service has been restored to Kaseya Quote Manager, and we are currently monitoring.
Posted Oct 27, 2025 - 08:48 EDT

Investigating

We are aware of a problem where Kaseya Quote Manager users are experiencing intermittent 504 errors when accessing or navigating the platform.

The Kaseya R&D Team is currently investigating.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Oct 27, 2025 - 06:46 EDT
This incident affected: Kaseya Quote Manager (Web Application, API, Integrations).