Datto Endpoint Backup for PC - Backup and Restore - Service Disruption for Customers Hosted on Cloud Siris 299242

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 10:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 08:11 EDT

Investigating

We are aware of a problem where Datto Endpoint Backup for PC users hosted on Cloud Siris 299242 may experience degraded backup and recovery performance..

The Kaseya Engineering Team is investigating the issue and working towards a resolution.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 03, 2026 - 15:20 EDT
This incident affected: Datto / Unitrends Endpoint Backup for PCs (Backup, Recovery).