Datto SaaS Protection - SaaS Protection Status Page in Datto Partner Portal Not Loading Customer Details

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 13:53 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 14, 2026 - 12:40 EDT

Monitoring

Our R&D team has identified the issue and have deployed configuration changes to allow the SaaS Protection Status Page within the Datto Partner Portal to load customer details again as well as restore customer account access for all affected partners. The team is closely monitoring the results of the changes made.
Posted Sep 14, 2026 - 10:51 EDT

Update

We are continuing to investigate this issue.
Posted Sep 14, 2026 - 10:30 EDT

Investigating

We are aware of a problem where Datto SaaS Protection Partners are unable to access their customer accounts due to the SaaS Protection Status Page within the Datto Partner Portal not loading customer details.

The Kaseya Engineering Team is actively investigating this issue.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 14, 2026 - 08:46 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Console Login, SaaS Protection Client Onboarding).