SaaS Alerts Microsoft Manage Service Interruption

Incident Report for Kaseya Inc

Resolved

We have observed that the Microsoft endpoint is performing as expected. This incident is now closed.
Posted May 13, 2026 - 09:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 14:09 EDT

Identified

The issue has been identified. One of the endpoints from Microsoft is responding properly sometimes and others is throwing an error. We have implemented retry functionality for that endpoint and are clearing all errors. We will continue to work on this until all impacted Microsoft connections are stable.
Posted May 11, 2026 - 11:12 EDT

Update

We are continuing to investigate this issue.
Posted May 11, 2026 - 10:39 EDT

Update

Kaseya R&D team is continuing to investigate the issue and working towards a resolution.
Posted May 11, 2026 - 06:30 EDT

Update

Kaseya R&D team is continuing to investigate the issue and working towards a resolution.
Posted May 11, 2026 - 03:01 EDT

Investigating

We are aware of the ongoing service interruption issue in SaaS Alerts Microsoft Manage Integration. Our team is investigating the issue and working towards a resolution.
Posted May 11, 2026 - 01:42 EDT
This incident affected: SaaS Alerts (Manage).