We are still experiencing issues with subset of VSA10 customers unable to use Remote control feature. Our team is actively working to restore functionality on the affected instances.
We apologize for any disruption this may cause.
- Kaseya Cloud Operations Team
Posted Apr 10, 2026 - 12:54 EDT
Update
Currently Application functionality for all the regions looks stable. We will continue to monitor the results and keep you posted accordingly.
We apologize for the inconvenience caused.
- Kaseya Cloud Operations Team
Posted Apr 10, 2026 - 06:23 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 05:43 EDT
Investigating
Our team has identified an issue with the file transfer feature across all VSA10 regions. We are actively working to restore functionality on the affected instances.
We apologize for any disruption this may cause.
- Kaseya Cloud Operations Team
Posted Apr 10, 2026 - 04:57 EDT
This incident affects: VSA 10 (APAC, EU, US, US - Andromeda10, EU - Andromeda10, APAC-Hosted-1, Integration Services, License Management, US - Remote Control, EU - Remote Control, APAC - Remote Control, Software Catalog).