Autotask PSA - AU01, AU02 - Redirected Emails via M365 Not Creating Items Within Autotask

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.

We can confirm that this incident was related to a third-party vendor. The vendor was able to identify and resolve the interruption, and as a result, Autotask functionality is now operational.
Posted Jul 02, 2025 - 09:45 EDT

Investigating

Our Engineering teams are currently investigating an issue where inbound emails to our AU01 & AU02 zones, which were redirected via M365, are not creating items within Autotask.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 02, 2025 - 03:34 EDT
This incident affected: Autotask PSA (Australia / New Zealand, Australia / New Zealand 2).