Kaseya Products - Service Disruption

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 09:04 EDT

Monitoring

Our teams have confirmed that service has normalized for the affected modules, and we are continuing to monitor.

For additional details, please visit the Microsoft Azure status page: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 18:31 EDT

Update

The Microsoft team continues to work to mitigate the issue.

For additional details, please visit their status page: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 17:15 EDT

Identified

The Microsoft team continues to work to mitigate the issue.

Access to the KaseyaOne Portal and modules that utilize SSO login from KaseyaOne are primarily impacted.
Posted Oct 29, 2025 - 13:46 EDT

Investigating

We are aware of a service disruption for multiple Kaseya products.

This disruption is due to an ongoing issue with Azure Services. Customers may experience issues when accessing Kaseya modules.

We are monitoring the Microsoft Azure Service Status Page: https://azure.status.microsoft/en-us/status, and will update this incident as information becomes available.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Oct 29, 2025 - 12:25 EDT
This incident affected: Kaseya Quote Manager (Web Application), Connectbooster (Portal), and KaseyaOne.