Datto SaaS Protection - Backup performance degradation for SharePoint services on pods 'use1-saas-p2' 'use1-saas-p6' and 'use1-saas-p7'

Incident Report for Kaseya Inc

Resolved

The root cause of the issues has been resolved. Backup success rates have returned to normal limits.
Posted Aug 13, 2025 - 07:06 EDT

Monitoring

The Kaseya R&D team has identified a root cause for the issues and has implemented a fix.

The health of the pods is currently being monitored for improvements.
Posted Aug 12, 2025 - 07:31 EDT

Update

We are continuing to investigate this issue.
Posted Aug 12, 2025 - 00:15 EDT

Update

We are continuing to investigate this issue.
Posted Aug 12, 2025 - 00:03 EDT

Update

We are continuing to investigate this issue.
Posted Aug 12, 2025 - 00:02 EDT

Investigating

We are aware of a problem where some Datto SaaS Protection customers hosted on pods 'use1-saas-p2' 'use1-saas-p6' and 'use1-saas-p7' may experience degraded backup performance.



The Kaseya R&D Team is currently investigating this issue.




Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 11, 2025 - 16:38 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).