Datto Workplace - Degraded Performance in US Regions

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 08:14 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 04:27 EDT

Identified

We are investigating reports of slow loading times affecting Workplace, the web portal, and agent connectivity for partners hosted in our US regions. A small number of users may also see intermittent connection errors when opening a project or folder.

Our engineering team has identified the issue and is working towards a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 12, 2026 - 17:56 EDT
This incident affected: Datto Workplace (US1, US6, US15).