Kaseya Product Support - Phone and Chat Support - Degraded
Incident Report for Kaseya Inc
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 08:48 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2024 - 09:30 EST
Investigating
We are aware of a problem where functions within the Kaseya Helpdesk, such as phone and chat support, are currently experiencing longer than average wait times.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 08, 2024 - 09:21 EST
This incident affected: Kaseya Product Support Contact Center (Phone Support, Chat).