Datto SaaS Protection - Backup performance degradation for some SharePoint/Teams services on pod 'gbe2-saas-p0'

Incident Report for Kaseya Inc

Update

We are continuing to monitor for any further issues.
Posted Jul 09, 2026 - 08:24 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 10:05 EDT

Investigating

We are aware of a problem where some customers hosted on pod 'gbe2-saas-p0' are experiencing backup performance degradation for some SharePoint and Teams services.

The Kaseya R&D Team is actively Investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 08, 2026 - 08:37 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).