Endpoint Backup v2 - UniView is exhibiting inconsistencies in backup reporting, resulting in inaccurate backup status visibility

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.

We will continue to monitor the environment to ensure ongoing stability. If you continue to experience any issues, please contact Kaseya Support.

We sincerely apologize for the disruption and thank you for your patience while we worked to resolve this issue.
Posted Jul 29, 2026 - 19:59 EDT

Monitoring

Our R&D team has implemented a fix, and we're seeing improved performance across the affected systems. We're continuing to monitor the environment to ensure the improvements are sustained.
Posted Jul 28, 2026 - 19:59 EDT

Update

We are continuing to investigate this issue.
Posted Jul 28, 2026 - 14:04 EDT

Investigating

We are aware of a problem where Endpoint Backup v2 assets in UniView may incorrectly indicate backup failures despite successful backup completion, which can trigger unnecessary email notifications.


The Kaseya R&D Team is investigating the issue and working towards a resolution.


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 28, 2026 - 08:52 EDT
This incident affected: Endpoint Backup V2 (Backup).