Datto RMM - Merlot and Pinotage - Device Filter results are not able to be returned

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 15:30 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2026 - 14:31 EDT

Investigating

We are aware of a problem where some device filters on Merlot and Pinotage are failing to load with an error pop-up saying: "Device Filter results were not able to be returned."

The Kaseya R&D Team are investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Mar 23, 2026 - 12:39 EDT
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2)).