Datto RMM - All Platforms - Microsoft 365 Integration Not Loading Tenant Data

Incident Report for Kaseya Inc

Postmortem

On 25th April 2025 around 18:00 UTC, Datto RMM partners using the Microsoft 365 integration experienced an issue that caused Tenant data loading to fail.

The root cause of the incident was identified to be an issue with backend application registration with Azure services.

The R&D team identified and resolved the issue which required a new application registration with the Azure service. This may result in some customers having to re-authenticate their integration, however, the sync status of the integration should have remained unchanged.

To help prevent this issue in the future, development work has been initiated to set up automatic monitoring and implement proactive measures before it can impact production.

Posted Apr 30, 2025 - 10:16 EDT

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 17:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.

Re-authenticating the integration may be required, but the tenant sync status should remain unchanged.
Posted Apr 25, 2025 - 17:04 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 25, 2025 - 15:33 EDT

Investigating

We are aware of a problem where the Microsoft 356 Integration may fail to load Tenant Data for all Datto RMM Platforms.
The Kaseya R&D Team are Investigating a root cause and are determining next steps.
Posted Apr 25, 2025 - 14:54 EDT
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2), Zinfandel (US West), Concord (US East), Syrah (APAC), Vidal (US East)).