Intuit has reported that API functionality has returned, and calls should be completing as expected. Our internal teams have confirmed that syncs are running now running as expected.
We advise Partners to compare data between ConnectBooster, and QuickBooks Online to ensure the data is up to date, and if not, to set their sync date back to 9/1/2026 - 1pm which was prior to the outage being reported by Intuit and allow for an accounting package sync to take place.
Thank you,
Posted Sep 02, 2026 - 08:52 EDT
Update
Intuit has updated their status page stating that this is a Major Outage within the Intuit system. They are still investigating the issue. This is currently affecting API calls resulting in sync failures causing delays in data syncing to and from QBO and ConnectBooster.
At this time, a valid workaround is not available, and we recommend that you subscribe to Intuit's Status Page for immediate updates. Our team will continue to provide status updates as they are received to the status page
Posted Sep 01, 2026 - 23:00 EDT
Monitoring
A recent degradation with Intuit's QuickBooks Online has been reported by Intuit. This is currently affecting API calls which may result in sync failures causing delays in data syncing to and from QBO and ConnectBooster. Our team is currently monitoring the status of this from Intuit's Status Page which can be found here: https://status.developer.intuit.com/
At this time, a valid workaround is not available, and we recommend that you subscribe to Intuit's Status Page for immediate updates. Our team will continue to provide status updates as they are received to the status page.