Datto SaaS Protection - Backup performance degradation for SharePoint services on pod 'use1-saas-p4'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 14:17 EDT

Update

SharePoint backup success rates on the pod have returned to normal. The Kaseya R&D team is continuing to monitor.
Posted Jun 25, 2025 - 09:28 EDT

Monitoring

The Kaseya R&D team has implemented configuration changes on the pod to address the issue and are monitoring the results.
Posted Jun 24, 2025 - 16:05 EDT

Identified

The issue has been identified and the Kaseya R&D team is working to implement changes to address it.
Posted Jun 24, 2025 - 14:05 EDT

Investigating

We are currently aware of a problem where some Datto SaaS Protection customers hosted on pod 'use1-saas-p4' are experiencing degraded backup performance for SharePoint services.


The Kaseya R&D Team is actively investigating.


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 24, 2025 - 11:06 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).