Datto RMM - Merlot (EMEA) - Job Service Failures

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 15:32 EDT

Monitoring

A fix has been implemented, and we are currently monitoring the results.
Posted Aug 13, 2026 - 05:52 EDT

Investigating

We are aware of an issue affecting the Merlot platform where Quick Jobs and Scheduled Jobs are failing to run.

The Kaseya Engineering Team is actively investigating the issue.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 13, 2026 - 05:24 EDT
This incident affected: Datto RMM (Merlot (EU2)).