DRMM (Syrah) -- Device Filter "Site Name" criterion ignored, returns devices from all sites

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 23:26 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 22:30 EDT

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 22:04 EDT

Investigating

We are aware of the issue where Filters no longer respect the "Site Name" Criteria resulting in devices that should not be included in the Filter are included in the Filter that then affects Policy/Job targeting.
Posted Jul 30, 2026 - 20:48 EDT
This incident affected: Datto RMM (Syrah (APAC)).