Datto SaaS Protection - Service disruption for customers hosted on node 'usw3-pod-1'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 13:27 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 08:40 EST

Investigating

We are aware of a problem where SaaS Protection customers hosted on node 'usw3-pod-1' are experiencing backup degradation.

The Kaseya R&D Team is currently investigating.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Mar 03, 2026 - 21:33 EST
This incident affected: Datto SaaS Protection (SaaS Protection Backups).