ConnectBooster - Emails - Delivery of emails may be impacted

Incident Report for Kaseya Inc

Resolved

After extensive monitoring of this event, our team believes this issue to be resolved.

Please reachout to our support team through the K1 Portal to submit a ticket if you have any questions.
Posted Aug 05, 2025 - 16:25 EDT

Update

Our team has implemented changes to the product to resolve this issue and are now currently monitoring for further changes or developments.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 01, 2025 - 09:31 EDT

Monitoring

Our team has implemented changes to the product to resolve this issue and are now currently monitoring for further changes or developments.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 01, 2025 - 09:29 EDT

Identified

We are aware of a problem where a small subset of our customers have reported emails being sent from the ConnectBooster platform are not delivering.

The Kaseya R&D Team has identified the issue and is working on a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 31, 2025 - 17:40 EDT
This incident affected: Connectbooster (Portal).