DarkWeb ID - 503 Service Temporarily Unavailable Errors

Incident Report for Kaseya Inc

Postmortem

On April 23, 2025 around 16:40 UTC, DarkWeb ID Partners experienced a service interruption which caused the service to be unavailable showing a "503 Service Temporarily Unavailable" error.

The root cause for this service interruption was caused by infrastructure dependencies on 3rd party libraries.

 

Our Engineering team deployed a fix to correct the problem on April 23, 2025 around 17:30 UTC.

Posted Apr 24, 2025 - 12:46 EDT

Resolved

Performance has been restored to normal. This incident is resolved.
Posted Apr 23, 2025 - 12:46 EDT

Monitoring

The R&D team have implemented a fix. Users should now be able to access DarkWeb ID. Some performance degradation is still present and the R&D team continues to work on restoring full performance.
Posted Apr 23, 2025 - 12:32 EDT

Investigating

We are aware of a problem where all DarkWeb ID sites lead to a 503 Service Temporarily Unavailable error page

The Kaseya R&D Team are Investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Apr 23, 2025 - 12:14 EDT
This incident affected: Dark Web ID.