Autotask - UK01 and UK02 Zones - Emails not being sent or received

Incident Report for Kaseya Inc

Resolved

Microsoft has fixed the issue with receiving email from external domains. We have verified that emails are now getting processed without issue. This incident is resolved.
Posted Sep 04, 2026 - 15:40 EDT

Identified

We are aware of a problem where users on UK01 and UK02 who use Outlook as their email service are not having their Emails be sent and received.

The Kaseya Engineering Team have identified the issue and are working with Microsoft to resolve it.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 04, 2026 - 08:43 EDT
This incident affected: Autotask PSA (UK (United Kingdom), UK 2 (United Kingdom)).