Endpoint Backup v2 - Service degradation - interface actions, registration and jobs may require retry

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 16:03 EDT

Investigating

Identified - We are aware of a problem where Endpoint Backup v2 customers may experience problems performing actions in the web interface. And backup jobs may be impacted.

The Kaseya R&D Team is actively investigating. In the meantime, if an issue is encountered, please retry the task at hand.

Resolved: This issue has been resolved.
Posted Jun 10, 2025 - 18:34 EDT
This incident affected: Endpoint Backup V2 (Backup, Agent Registration, Restore).