Endpoint Backup v2 - Backup Service Interruption with Impacted Asset Visibility in Uniview Portal

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 12:58 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 11:51 EST

Investigating

We are aware of a problem where Endpoint Backup v2 assets are currently experiencing an issue where scheduled backups are not executing, and associated assets are not appearing in the Uniview Portal.



The Kaseya R&D Team is currently investigating the issue and working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Dec 04, 2025 - 10:25 EST
This incident affected: Endpoint Backup V2 (Backup, Agent Registration, Restore).