Datto SaaS Protection - New customer onboarding is unavailable

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 11:58 EDT

Monitoring

A fix for the issue has been deployed and the SaaS Protection onboarding service has been restored.
Posted Jun 05, 2026 - 11:47 EDT

Update

A fix for this issue has been tested and is being prepared for release.
Posted Jun 05, 2026 - 11:19 EDT

Identified

We are aware of a problem where Datto SaaS Protection Partners are currently unable to onboard new customers within the Partner Portal and are receiving an error.

The Kaseya R&D Team has identified the issue and they are actively working on a fix.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 05, 2026 - 10:38 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Client Onboarding).