VSA10 - Degraded Performance for APAC Customers

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 19:15 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2025 - 18:15 EST

Investigating

We are currently experiencing degraded performance, which may impact administrators' ability to manage endpoints.

Our team is actively working to restore full functionality on the affected servers.

We apologize for any disruption this may cause.

- Kaseya Cloud Operations Team
Posted Nov 07, 2025 - 17:48 EST
This incident affected: VSA 10 (APAC, APAC-Hosted-1).