VSA9 - Partial Service Disruption - liveconnect.me

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 16:54 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2026 - 16:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 16:00 EDT

Investigating

We are currently experiencing a partial service disruption affecting a subset of customers using VSA9 LiveConnect (liveconnect.me).
Customers may notice issues accessing LiveConnect on-demand services.

Our team is working to restore the functionality on the affected instances at this time.

We apologize for any inconvenience.

- Cloud Operations Team
Posted Apr 23, 2026 - 11:58 EDT
This incident affected: VSA 9.