Datto RMM - Intermittent Job Creation Failures on the Syrah (APAC) and Vidal (US East) platforms

Incident Report for Kaseya Inc

Monitoring

The fix has been implemented on both the Syrah and Vidal platforms.
Posted Jul 01, 2026 - 06:20 EDT

Identified

The Kaseya R&D Team identified the cause of the issue where Jobs intermittently fail to be created in the Web UI.

The fix for the problem is currently being tested, and it is planned to be deployed in the coming days.
Posted Jun 30, 2026 - 09:26 EDT
This incident affects: Datto RMM (Syrah (APAC), Vidal (US East)).