VSA9 - Partial Service Disruption - US-NA1VSA37

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 12:27 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 11:24 EST

Investigating

We are experiencing a partial service disruption on na1vsa37 that may affect the application functionality. Our team is working to restore functionality on the instance at this time.

We apologize for any inconvenience.

- Kaseya Cloud Operations Team
Posted Jan 12, 2026 - 10:48 EST
This incident affected: VSA 9 (US - NA1VSA37).