IT Glue - Network Glue - Network Glue pages are not loading and users are unable to create new networks

Incident Report for Kaseya Inc

Resolved

The Kaseya R&D team have deployed a fix to Network Glue that resolves all issues with pages loading and creating new networks. This issue is now resolved.
Posted Jul 02, 2025 - 14:21 EDT

Monitoring

We are aware of a problem where Network Glue pages are not loading and users are unable to create new networks.

The cause of this issue is from additional load on our back end systems.

The Kaseya R&D Team have deployed additional resources to handle this load and are monitoring performance.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 30, 2025 - 13:32 EDT
This incident affected: IT Glue (Network Glue).