DattoRMM - Vidal - Activity Log pages are slow to load

Incident Report for Kaseya Inc

Resolved

The issue affecting Activity Log performance on the Vidal Platform following the 15.1 release has been resolved.

The Kaseya Engineering Team implemented a fix and has confirmed that Activity Logs are loading as expected after monitoring the platform to ensure ongoing stability and performance.

Should you have any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 28, 2026 - 14:43 EDT

Monitoring

We are aware of a problem where the Activity Logs on our Vidal Platform are slow to load after our 15.1 release.

The Kaseya Engineering Team has applied a fix and is currently monitoring this closely.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 21, 2026 - 13:17 EDT
This incident affected: Datto RMM (Vidal (US East)).