Datto Workplace - Latency Issues Affecting Users on US Cells

Incident Report for Kaseya Inc

Update

We have identified the root cause of the slow file downloads impacting large projects. The issue is isolated to the server side and does not impact data integrity. A corrective solution is currently under evaluation, and we anticipate providing an updated status early next week.
Posted Apr 03, 2026 - 13:06 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 03, 2026 - 09:32 EDT

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 09:02 EDT

Investigating

We are aware of a problem where Datto Workplace users are reporting elevated latency impacting multiple projects within the U.S. region.



The Kaseya R&D Team is currently investigating the issue and working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Apr 01, 2026 - 11:45 EDT
This incident affects: Datto Workplace (US1, US6, US15).