Datto BCDR - Increase Backup Failure Rate Due to Certificate-Related Errors

Incident Report for Kaseya Inc

Identified

We have identified an increased rate of backup failures due to error "Critical backup failure during data transfer (Certificate error communicating with Agent)" for Datto BCDR products.

Our R&D team has been alerted to this and is actively investigating the issue, however, If you have agents experiencing this error, please ensure that the agents have outbound access to the following on port 443:

device.dattobackup.com

cf-dl.datto.com

agent-update.datto.com

mothership.dtc.datto.com

tmp.datto.net

ocsp.digicert.com

e8.i.lencr.org

valid-isrgrootx1.letsencrypt.org


Please take a moment to review the network requirements outlined below, as any deviations from these configurations may contribute to the behavior you are experiencing:

https://continuity.datto.com/help/Content/kb/siris-alto-nas/200555135.html#Internet

https://continuity.datto.com/help/Content/kb/siris-alto-nas/KB213994246.html

Verifying that these configurations are properly implemented will help eliminate known environmental variables as potential contributors.

Additionally, please be aware that certain firewall traffic inspection features may also contribute to these conditions.

More information will be shared as it becomes available.
Posted Jan 20, 2026 - 13:02 EST

Investigating

We have identified an increased rate of backup failures due to error "Critical backup failure during data transfer (Certificate error communicating with Agent)".



Our R&D team has been alerted to this and is actively investigating the issue.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jan 19, 2026 - 15:56 EST
This incident affects: Datto BCDR Devices (Backup).