Datto SaaS Protection - Degraded backup performance for services on node 'gbe2-bfyii-328'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 08:29 EDT

Monitoring

Backup frequency on node 'gbe2-bfyii-328' has been increased to 3x backups per day again.

The R&D team is monitoring.
Posted Oct 24, 2025 - 09:36 EDT

Update

Our R&D team has temporarily reduced the frequency of backups on node 'gbe2-bfyii-328' from 3x per day to 1x per day to reduce load on the system and stabilize the performance of services while they perform maintenance.

Please note that systems and related services to Datto SaaS Protection on node 'gbe2-bfyii-328' will remain operational while maintenance is active.
Posted Oct 07, 2025 - 09:49 EDT

Identified

We are aware of a problem where some customers hosted on node 'gbe2-bfyii-328' are experiencing degraded backup performance for some services.

The Kaseya R&D Team has identified the issue and are working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Oct 06, 2025 - 14:39 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).